aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/libtxc_dxtn.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srcds-pkgs/libtxc_dxtn.nix')
-rw-r--r--srcds-pkgs/libtxc_dxtn.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/srcds-pkgs/libtxc_dxtn.nix b/srcds-pkgs/libtxc_dxtn.nix
new file mode 100644
index 0000000..6bd3828
--- /dev/null
+++ b/srcds-pkgs/libtxc_dxtn.nix
@@ -0,0 +1,25 @@
+{ lib, stdenv, fetchurl, autoreconfHook, libGL, libGLU, runCommand, fakegl }:
+stdenv.mkDerivation rec {
+ pname = "libtxc_dxtn";
+ version = "1.0.1";
+
+ src = fetchurl {
+ url = "https://people.freedesktop.org/~cbrill/libtxc_dxtn/${pname}-${version}.tar.bz2";
+ sha256 = "0q5fjaknl7s0z206dd8nzk9bdh8g4p23bz7784zrllnarl90saa5";
+ };
+
+ nativeBuildInputs = [ autoreconfHook ];
+ buildInputs = [ libGL libGLU ] ++ lib.optional stdenv.isDarwin fakegl;
+
+ postPatch = lib.optionalString stdenv.isDarwin ''
+ substituteInPlace Makefile.am --replace \
+ "-avoid-version -module" \
+ "-avoid-version -static"
+ '';
+ meta = with lib; {
+ homepage = "http://dri.freedesktop.org/wiki/S3TC";
+ repositories.git = "git://people.freedesktop.org/~mareko/libtxc_dxtn";
+ license = licenses.mit;
+ platforms = platforms.unix;
+ };
+}