aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
committeryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
commit56449e59d7aabd1c06fb67a51a1e129b55cb9270 (patch)
tree19f3faf805e9b6461a5940d1a050d13e5271ef55 /flake.nix
break out of system config
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..5c2bc84
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,10 @@
+{
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.05";
+
+ outputs = { self, nixpkgs, ... }@inputs: {
+ overlays.default = import ./overlay.nix;
+ packages = builtins.mapAttrs
+ (_arch: pkgs: { default = import ./default.nix pkgs; })
+ nixpkgs.legacyPackages;
+ };
+}