aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/ambuild.nix
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
committeryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
commit56449e59d7aabd1c06fb67a51a1e129b55cb9270 (patch)
tree19f3faf805e9b6461a5940d1a050d13e5271ef55 /srcds-pkgs/ambuild.nix
break out of system config
Diffstat (limited to 'srcds-pkgs/ambuild.nix')
-rw-r--r--srcds-pkgs/ambuild.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/srcds-pkgs/ambuild.nix b/srcds-pkgs/ambuild.nix
new file mode 100644
index 0000000..5621f49
--- /dev/null
+++ b/srcds-pkgs/ambuild.nix
@@ -0,0 +1,23 @@
+{ lib, buildPythonPackage, fetchFromGitHub }:
+let
+ owner = "alliedmodders";
+in buildPythonPackage rec {
+ pname = "ambuild";
+ version = "2024-07-07";
+
+ src = fetchFromGitHub {
+ inherit owner;
+ repo = pname;
+ rev = "551dd3f630f90377cbe536fbaf12e0b6bca91253";
+ sha256 = "1xfjxs3ajrrz66pdspwrnr5faifk1r3i5nha8vmz510z07h5g6g3";
+ };
+
+ # doCheck = false;
+
+ meta = with lib; {
+ description = "Lightweight build system designed for performance and accuracy";
+ homepage = "https://github.com/${owner}/${pname}";
+ platforms = platforms.unix;
+ license = licenses.bsd3;
+ };
+}