aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/fakegl.nix
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2024-12-15 06:12:40 -0800
committeryuuko <yuuko@partyvan.io>2024-12-15 06:12:40 -0800
commit0a08e401d26785638c09ce378c282924e3ddbaf9 (patch)
treeca79cf4a9de71a186f89ac3502c71ae81143bfa1 /srcds-pkgs/fakegl.nix
parent0d7306a1ed22896a4d213a8c8057d488a9912702 (diff)
pkgs: add some texture authoring tools
Diffstat (limited to 'srcds-pkgs/fakegl.nix')
-rw-r--r--srcds-pkgs/fakegl.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/srcds-pkgs/fakegl.nix b/srcds-pkgs/fakegl.nix
new file mode 100644
index 0000000..e16e8f1
--- /dev/null
+++ b/srcds-pkgs/fakegl.nix
@@ -0,0 +1,7 @@
+{ libGL, runCommand }:
+runCommand "fakegl" {} ''
+ mkdir -p $out/include/{GL,OpenGL}
+ framework=${libGL}/Library/Frameworks/OpenGL.framework/Headers
+ ln -s $framework/gl.h $out/include/GL/
+ ln -s $framework/{gl{ext,types},OpenGLAvailability}.h $out/include/OpenGL/
+''