aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/vtflib-strata/CMakeLists.txt.append
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2025-01-01 19:47:54 -0800
committeryuuko <yuuko@partyvan.io>2025-01-01 19:47:54 -0800
commitdc13851344b52051c8b72cc6a2ff49753a87091e (patch)
tree6ffdc84b16ae48f7ec6d0e669c692c4368027291 /srcds-pkgs/vtflib-strata/CMakeLists.txt.append
parent9eac1ae0e3d1d9ea19d354986b30866b09f74763 (diff)
vtflib-strata: patch in a pkg-config fileHEADmaster
Diffstat (limited to 'srcds-pkgs/vtflib-strata/CMakeLists.txt.append')
-rw-r--r--srcds-pkgs/vtflib-strata/CMakeLists.txt.append2
1 files changed, 2 insertions, 0 deletions
diff --git a/srcds-pkgs/vtflib-strata/CMakeLists.txt.append b/srcds-pkgs/vtflib-strata/CMakeLists.txt.append
index 51b947e..ca18583 100644
--- a/srcds-pkgs/vtflib-strata/CMakeLists.txt.append
+++ b/srcds-pkgs/vtflib-strata/CMakeLists.txt.append
@@ -10,3 +10,5 @@ install (TARGETS vtflib vtflib_static
ARCHIVE DESTINATION lib
PUBLIC_HEADER DESTINATION include
)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/vtflib.pc.in ${CMAKE_CURRENT_BINARY_DIR}/vtflib.pc @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/vtflib.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)