aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/vtflib.nix
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2024-12-15 06:12:40 -0800
committeryuuko <yuuko@partyvan.io>2024-12-15 06:12:40 -0800
commit0a08e401d26785638c09ce378c282924e3ddbaf9 (patch)
treeca79cf4a9de71a186f89ac3502c71ae81143bfa1 /srcds-pkgs/vtflib.nix
parent0d7306a1ed22896a4d213a8c8057d488a9912702 (diff)
pkgs: add some texture authoring tools
Diffstat (limited to 'srcds-pkgs/vtflib.nix')
-rw-r--r--srcds-pkgs/vtflib.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/srcds-pkgs/vtflib.nix b/srcds-pkgs/vtflib.nix
new file mode 100644
index 0000000..a2dd600
--- /dev/null
+++ b/srcds-pkgs/vtflib.nix
@@ -0,0 +1,32 @@
+{ lib, stdenv, fetchFromGitHub, cmake, libtxc_dxtn
+, libGLU, fakegl }:
+let
+ gl = if stdenv.isDarwin then fakegl else libGLU;
+in
+stdenv.mkDerivation rec {
+ pname = "VTFLib";
+ version = "2022-10-08";
+
+ src = fetchFromGitHub {
+ owner = "panzi";
+ repo = pname;
+ rev = "eaca22de46dc62ccfbac6720a68ae3a82b86907e";
+ hash = "sha256-Q2puLqOZSJ2ZO06U8M8Khs4uRzh1vdPptRlzmfi874M=";
+ };
+
+ nativeBuildInputs = [ cmake ];
+ buildInputs = [ libtxc_dxtn gl ];
+
+ postPatch = ''
+ substituteInPlace VTFLib.pc.in --replace \
+ "''${exec_prefix}/@CMAKE_INSTALL_LIBDIR@" \
+ "@CMAKE_INSTALL_FULL_LIBDIR"
+ '';
+
+ meta = {
+ homepage = src.url;
+ description = "Linux port of Nem's VTFLib";
+ license = lib.licenses.lgpl21Plus;
+ platforms = lib.platforms.unix;
+ };
+}