aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/depotdownloader-json/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srcds-pkgs/depotdownloader-json/default.nix')
-rw-r--r--srcds-pkgs/depotdownloader-json/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/srcds-pkgs/depotdownloader-json/default.nix b/srcds-pkgs/depotdownloader-json/default.nix
new file mode 100644
index 0000000..c09422d
--- /dev/null
+++ b/srcds-pkgs/depotdownloader-json/default.nix
@@ -0,0 +1,10 @@
+{ depotdownloader }:
+depotdownloader.overrideAttrs({ patches ? [], version, ... }: {
+ patches = assert builtins.elem version [ "2.4.7" "2.5.0" ]; patches ++ [
+ # with this, nix has access to the hashes in the manifest
+ ./0001-emit-json-in-.DepotDownload.patch
+ # the manifest can arrive out of order across requests to the same build!
+ # luckily that singular reproducibility snag is patched in 1 line.
+ ./0002-ProtoManifest-sort-files-in-constructor.patch
+ ];
+})