aboutsummaryrefslogtreecommitdiff
path: root/srcds-pkgs/mkdepot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'srcds-pkgs/mkdepot.nix')
-rw-r--r--srcds-pkgs/mkdepot.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/srcds-pkgs/mkdepot.nix b/srcds-pkgs/mkdepot.nix
index 8c1acaa..26d364b 100644
--- a/srcds-pkgs/mkdepot.nix
+++ b/srcds-pkgs/mkdepot.nix
@@ -1,5 +1,8 @@
{ lib, runCommand, fetchDepotFile }:
-name: caches: ps:
+{ name
+, caches
+, postScript ? ""
+}:
with lib;
let
emitStep = { FileName, Flags, Chunks, ... }@file:
@@ -15,5 +18,5 @@ let
in concatMapStrings mkStep (importJSON json).Files;
in runCommand name {} ''
${concatMapStringsSep "\n" emitManifest caches}
- ${ps}
+ ${postScript}
''