aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authoryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
committeryuuko <yuuko@partyvan.io>2024-08-29 21:51:04 -0700
commit56449e59d7aabd1c06fb67a51a1e129b55cb9270 (patch)
tree19f3faf805e9b6461a5940d1a050d13e5271ef55 /default.nix
break out of system config
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..6254ecb
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,7 @@
+let
+ purity = if builtins ? currentSystem then
+ import <nixpkgs> {}
+ else
+ throw "OOPS: srcds-nix/default.nix called without pkgs in a pure context";
+in
+{ pkgs ? purity, ... }: pkgs.callPackage ./srcds-pkgs {}