aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..6254ecb
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,7 @@
+let
+ purity = if builtins ? currentSystem then
+ import <nixpkgs> {}
+ else
+ throw "OOPS: srcds-nix/default.nix called without pkgs in a pure context";
+in
+{ pkgs ? purity, ... }: pkgs.callPackage ./srcds-pkgs {}